I've Released the Certificate, but it Still Appears to be Checked Out to Me

Problem

The certificate is released, but it still appears to be checked out in my MyCentre display.

Possible Cause

Perhaps the certificate was successfully released, but the MyCentre display is not refreshed, and is therefore not showing the current status.

Solution

Refresh your MyCentre display, and see whether the certificate is still checked out to you. The display may be refreshed in two manners:

  • Select the F5 (refresh) button on your machine. 
  • Re-open the WorkGroups page, by clicking on the WorkGroups tab and then selecting your WorkGroup.

If the Matter Persists

If the above suggestion does not resolve the matter, please feel free to report this to our support desk (support@mhi.ca).

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